Frage zu LED

Alles was mit der PC_DIMMER Hardware zu tun hat
Antworten
dragonfly45
Leuchtmittelaustauscher
Beiträge: 25
Registriert: 03.08.2012, 09:58

Frage zu LED

Beitrag von dragonfly45 » 19.01.2013, 17:05

Hallo,
bin gerade dabei meinen Dimmerpack in Betrieb zu nehmen. Alles verdrahtet, AVR programmiert. Beim Einschalten leuchtet die gelbe LED, dann leuchtet die grüne LED und die gelbe blinkt. Ist das erst mal richtig? , da das Dimmerpack noch kein Signal vom DMX-Interface bekommt.

MfG Dietmar

Benutzeravatar
admin
PC_DIMMER-Entwickler
Beiträge: 1808
Registriert: 12.11.2007, 09:30
Wohnort: Knw.-Remsfeld
Kontaktdaten:

Re: Frage zu LED

Beitrag von admin » 20.01.2013, 10:26

Hallo,

ja, das ist korrekt. Die LED-Signalcodes sind auch hier aufgeführt: http://www.pcdimmer.de/index.php/dmx512 ... switchpack

Dort auf der Seite mal auf "STERN LED-Anzeige" klicken. Es wird folgender Text angezeigt:
Die beiden Status-LEDs zeigen in der Originalfirmware den aktuellen Zustand der Firmware an. Es gibt derzeit (Firmware Version 4.3) folgende Kombinationen:

Beim Einschalten des Mikrocontrollers leuchtet zunächst nur Gelb, dann nur Grün und nach erfolgreichem Start entsprechend des aktuellen Zustandes wie ab 2. beschrieben:
Grün leuchtet dauerhaft: alles OK
Grün leuchtet und Gelb blinkt gleichmäßig schnell: DMX512-Signal fehlt
Grün leuchtet und Gelb blinkt/leuchtet: DMX-Werte werden geändert
Grün und Gelb blinken gleichzeitig: AC-Netz fehlt oder ZC-Detection fehlerhaft

Beim programmieren der Startadresse über den Schalter leuchten die LEDs entsprechend dem folgenden Muster:

Taster wird gedrückt: Grüne LED blinkt langsam um Beginn der Programmierung zu signalisieren. Hier kann der Vorgang durch Loslassen der Taste sofort abgebrochen werden, ohne eine Änderung vorzunehmen
Nach wenigen Sekunden blinkt die Grüne LED schnell. Hier wird auf die Informationen des Kanals 511 und 512 gewartet, von denen die Startadresse gelesen wird
Nach erfolgtem Auslesen der beiden Kanäle blinken Grün und Gelb gleichzeitig. Die Startadresse wurde erfolgreich ins EEPROM geschrieben. Der Taster kann nun losgelassen werden. Die grüne LED leuchtet nun wieder konstant.

viele Grüße,
Christian

Antworten