(Meine) fehlerhafte Gerätedefinition

Alles was nicht direkt mit dem normalen Verhalten des PC_DIMMERs zu tun hat
Antworten
prinzQMP
Beiträge: 2
Registriert: 11.11.2022, 12:08

(Meine) fehlerhafte Gerätedefinition

Beitrag von prinzQMP »

Moin,

ich habe gleich mehrere Probleme mit meiner DDF:
LIXADA Moving Head.pcddevc
(15.85 KiB) 9-mal heruntergeladen
A: Eine Farbe taucht in der Auswahl im Gerätefenster nicht auf
B: Angezeigte Farbe im Faderpanel ist falsch
C: Colors / Gobos lassen sich im Touchscreen nicht richtig durchschalten

Ich verstehe leider null, an welcher Stelle ich suchen muss.
Vielleicht ist beim manuellen Coden was kaputt gegangen.
Ich hatte z.B. aus Versehen zwei mal die Gerätedefinition erstellt und musste wieder Dinge raus nehmen.
Aber im Code sehe ich nichts was mir Dinge dinge erklärt.


Hier nochmal im Detail:

A: "Green" wird nicht in der Auswahl im Gerätefenster angezeigt.
Im GeräteEditor ist es unter Kanäle sichtbar.
Hier ist der (vermutlich) relevante Code

Code: Alles auswählen

<colors>
  <color name="White" value="0" valueend="15" r="255" g="255" b="255" />
  <color name="Red" value="16" valueend="31" r="255" g="0" b="0" />
  <color name="Light Blue" value="32" valueend="47" r="0" g="255" b="255" />
  <color name="Orange" value="48" valueend="63" r="255" g="128" b="64" />
  <color name="Blue" value="64" valueend="79" r="0" g="0" b="255" />
  <color name="Yellow" value="80" valueend="95" r="255" g="255" b="0" />
  <color name="Green" value="96" valueend="111" r="0" g="255" b="0" />
  <color name="Lila" value="112" valueend="127" r="255" g="0" b="255" />
  <color name="fast2slow" value="128" valueend="189" r="0" g="0" b="0" />
  <color name="Stop" value="190" valueend="193" r="0" g="0" b="0" />
  <color name="slow2fast" value="194" valueend="255" r="0" g="0" b="0" />
 </colors>
Wunderlicherweise werden in der Auswahl im Gerätefenster die deutschen Farbnamen angezeigt und nur "fast2slow", nicht aber "Stop", "slow2fast".
Kann es sein, das irgendwo Code existiert, an den ich nicht ran komme und der noch veraltet ist?

B: Die Prozentanzeige im Faderpanel zum entsprechenden Kanal wechselt ja eigentlich entsprechend die Farbe
Sie ist hier zu erst weiß,
wird schwarz wenn Sie rot werden sollte,
und ist dann für alle weiteren Farben Hellblau.
Es kann wie gesagt sein, dass es aus einer früheren Fehlerhaften Einstellung kommt ... aber wo existiert die noch!?

C: Im Touchscreen lassen sich mit "Gobo 1 +" und "Color 1 +" eigentlich Gobo und Farbe ändern.
Das funktioniert im Normalfall gar nicht. bzw. Farbe nur zwischen 0% und 2% O.o
Wenn ich Color am Regler hochstell hüpft Sie bei "+" immer auf 19%
Mit "-" geht es bei >2% immer auf 2% und dann auf 0%.
Zu den Gobos:

Code: Alles auswählen

 <gobos>
  <gobo name="Spiral" value="0" valueend="7" filename="Turbine.png" />
  <gobo name="Corona" value="8" valueend="15" filename="dotcircle2.png" />
  <gobo name="Offen" value="16" valueend="23" filename="1.png" />
  <gobo name="Zähne" value="24" valueend="31" filename="R0000032.png" />
  <gobo name="Tunnel" value="32" valueend="39" filename="Tunnel10.png" />
  <gobo name="Knoten" value="40" valueend="47" filename="knot.png" />
  <gobo name="Borg" value="48" valueend="55" filename="BreakUpRectangles.png" />
  <gobo name="Blasen" value="56" valueend="63" filename="Holes7.png" />
  <gobo name="Jitter Spiral" value="64" valueend="71" filename="" />
  <gobo name="Jitter Corona" value="72" valueend="79" filename="" />
  <gobo name="Jitter Offen" value="80" valueend="87" filename="" />
  <gobo name="Jitter Zähne" value="88" valueend="95" filename="" />
  <gobo name="Jitter Tunnel" value="96" valueend="103" filename="" />
  <gobo name="Jitter Knoten" value="104" valueend="111" filename="" />
  <gobo name="Jitter Blasen" value="120" valueend="127" filename="" />
  <gobo name="Fast2Slow" value="128" valueend="189" filename="" />
  <gobo name="Stop" value="190" valueend="193" filename="" />
  <gobo name="Slow2Fast" value="194" valueend="255" filename="" />
 </gobos>
Die Gobos funktionieren solange ich im Jitter bereich bin perfekt.
Aber ignorieren alles davor!?


Was zur Hölle ist hier los?
Ich habe das Gefühl da ist Geistercode von meinen Anfängen an den ich nicht ran komme.
Oder ich bin einfach zu dämlich irgendwas banales zu sehen.
Ich weiß einfach nicht mehr weiter.
Antworten