Kleiner Bug im Midi-Editor, Frage zu Master

Fragen die Hardware betreffend
Antworten
Wobex
Beiträge: 1
Registriert: 19.05.2016, 10:32

Kleiner Bug im Midi-Editor, Frage zu Master

Beitrag von Wobex » 19.05.2016, 12:03

PCD 5.4.5 Build 4704, Windows 10 64 Bit und Windows XP SP3 32 Bit:

Ein kleiner Bug und eine Ungereimtheit sind mir beim Midi-Editor aufgefallen.

Zuordnen von Programchanges zu Szenen/Effekten etc...:
Im Midi-Event-Editor stelle ich dann z.B. ein
Message = 192 (PGMChange auf Midikanal 1), Wert aus Byte 1, Untere Gr. =1, Schaltschwelle=1, Obere Gr. =1
PgmChange 1 wird einwandfrei erkannt und löst eine zugeordnete Aktion (Szene, Effekt, Sonstwas) aus. Wunderbar!

Aber bei PGMChange 0 gibt es ein Problem. Die nötige Einstellung wäre
Message = 192 (PGMChange auf Midikanal 1), Wert aus Byte 1, Untere Gr. =0, Schaltschwelle=0, Obere Gr. = 0.
Allerdings kann ich die oberer Grenze nicht auf 0 stellen, da steht immer mindestens eine 1 drin. Was zur Folge hat, das die für den PGMChange 0 vorgesehene Aktion auch ausgelöst wird, wenn PGMChange 1 über Midi gesendet wird.
Da wäre es gut, wenn auch die 0 in obere Grenze stehen könnte.

Weiterhin ist mir aufgefallen, dass beim Zuordnen von Szenen zu einem MidiEvent der Szenenname nach erfolgter Zuordnung nicht angezeigt wird. Da ist ein wenig irritierend, weil man - wenn man so schusselig ist wie ich - nicht weiß, ob man die Zuordnung schon durchgeführt hat oder nicht. Man sieht es erst nach Verlassen des Editors in der Auflistung der konfigurierten Midi-Ereignisse.

Aber ansonsten: Funktioniert prima, die Midisteuerung. Ich verwende sie für Szenenauswahl, Effekteauswahl und Sub- und Master-Steuerung.

A pro pos Master:
Der Master steuert die Werte aller R, G, B, Y, W, A und DIMMER Kanäle habe ich gelesen. Aber meine W, A und YELLOW-Kanäle wollen sich einfach nicht nach dem Master richten. R, G, B und DIMMER funktionieren. Habe ich da was falsch verstanden?

Ingo
< PC_DIMMER >
Beiträge: 533
Registriert: 19.03.2009, 17:49
Wohnort: Bad Hersfeld bzw. Stuttgart

Re: Kleiner Bug im Midi-Editor, Frage zu Master

Beitrag von Ingo » 20.05.2016, 19:47

Wenn du z.B. Tasten abfragen willst, die einmalig einen Wert senden, solltest du in der Regel den Wert aus Byte 2 beziehen (ist dann unbenutzt) und Data1 entsprechend einstellen; in deinem Fall also einmal 0, einmal 1.

Zum Master: Ich kann das reproduzieren, und habe im Code noch einige Kleinigkeiten mehr gefunden. Dazu habe ich ein Issue verfasst (hoffe, meine Interpretation stimmt). Ich selbst kanns leider nicht fixen, da ich keine lauffähige Entwicklungsumgebung für PC_DIMMER habe.

Grüße,
Ingo

Antworten